Intermittent Performance Issues
Incident Report for EdSmart Platform Status
Resolved
We have been monitoring platform performance and no issues have been recorded in over two weeks. We are marking this incident as resolved. If you experience any issues in the future please contact our Support team at help@edsmart.com.
Posted Apr 15, 2021 - 13:51 AEST
Update
The Engineering Team has taken steps to address the recent platform performance which has since produced positive performance stability. The team continues to monitor for any issues and will respond accordingly.
Posted Mar 30, 2021 - 11:10 AEDT
Update
Our Engineering have increased capacity on the database to account for high levels of activity on the platform. This may have resulted in loss of access to EdSmart for 1-2 minutes. Response times are now starting to improve as a result.
Posted Mar 29, 2021 - 14:55 AEDT
Update
Our Engineering team have put in place several improvements to platform performance, and we have seen stability on the platform for the last month.

However, we are aware of a slowdown on the platform this afternoon. It appears that this relates to a high load on the database, corresponding with a spike in sending and responding to Slips and Broadcasts. Response times are now improving and we will continue to monitor performance, in addition to broader efforts to improve performance on the platform.
Posted Mar 29, 2021 - 14:44 AEDT
Monitoring
We have put in place several measures to address the intermittent performance degradation we have been experiencing recently, including optimisation of database resources and rescheduling of background functions. We have also increased the scope of proactive monitoring, and implemented new tracing capabilities to help with performance analysis and improvement in the short term. We believe that these changes will have a significant impact, however our investigations are ongoing and we will provide further updates as they are available.
Posted Feb 10, 2021 - 17:40 AEDT
Update
At approximately 1.50pm and again at 3.30pm AEST today our primary database became saturated with a very large number of concurrent connections. The effect for the end user using EdSmart is a significant slow down in performance whilst the database infrastructure endeavours to service all the requests.
This occurred on a previous occasion and our Engineering team has been engaged in a series of mitigation activities, including conferencing with domain experts at our hosting company, Microsoft Azure.
The slow down lasts a relatively short window, but obviously for people using EdSmart at the time it leads to frustrations over long load times. EdSmart usage is some 50% above the same time next year, and other than these couple of short blips, the technology platform has been stable and performing as normal.
Our Engineering team, with help from Microsoft, is continuing to work to identify the source of the issue.
Posted Feb 09, 2021 - 17:14 AEDT
Investigating
We are aware of a slowdown on the platform. Our Engineering team is investigating the issue. We apologise for any inconvenience. We will be providing updates with any developments.
Posted Feb 09, 2021 - 16:17 AEDT
This incident affected: Application.